Problem
The StackState ServiceNow integration returns the error 'Transaction cancelled: maximum execution time exceeded' when retrieving data from ServiceNow.
Cause
The ServiceNow REST Table API request timeout is not high enough to process an API call from StackState for the configured batch_size.
Solution
Increase the configured timeout in ServiceNow or reduce the batch size in the StackState Agent:
- Set a higher REST Table API request timeout in ServiceNow (default 60 seconds). See Default quota rules (servicenow.com).
- Set a lower batch_size for the StackState Agent ServiceNow integration (default 10,000).
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